Les jeux, les machines d'arcade mais aussi les tutos pour créer et monter vous-même une borne d'arcade maison !
#399431 par Arvester
09 Juil 2017, 14:07
Bon, ben ça a fonctionné parfaitement pendant 10 minutes, et maintenant pour une raison inconnue les jeux plantent tous au chargement avec retour au menu... J'ai juste reparamétré les contrôles... si quelqu'un a une piste je suis preneur!
#399434 par Anonyme01
09 Juil 2017, 14:51
Remets d'origine les paramètres ! Et regarde petit à petit se qui fait merder
#399438 par Anonyme01
09 Juil 2017, 16:02
J'ai exclus se problème, mais en y repensant possible que tu es raison jelly
#399535 par Arvester
11 Juil 2017, 10:10
Je trifouille un peu les forums, semblerait que le Pi est été mal éteint (alors que je fais attention), ça a probablement foiré les listes de jeu en .xml. Faut juste que je les génère à nouveau. Et après test et réflexion, je vais devoir ajouter encore des boutons, au moins Y, peut-être aussi Start et Select même si ces derniers sont rarement utilisés en jeu.

Le problème doit venir du bouton on/off que j'ai ajouté, c'est pas géré parfaitement encore. Quand on branche le pi la première fois, il démarre, quelque soit la position du bouton. Ensuite quand on veut éteindre, on tourne le bouton (ce qui le met sur "on") et là ça éteint le pi... Bref j'ai du chier dans la colle pour remettre le bouton dans le bon sens à un moment sans me rendre compte, faudra que je pense simplement à le mettre sur on avant de brancher le pi... ensuite ça ira si je laisse la racecab branchée constamment. Pas pratique. Je vais peut-être oublier cette idée de on/off et câbler start à la place ^^' ça permettra d'ouvrir le menu et d'éteindre correctement la racecab à l'ancienne.

Edit: problem solved ; j'ai essayé de supprimer les gamelists xml et ça n'a rien fait, j'ai fini par tout formater et réinstaller au propre ^^ Je peux me re-concentrer sur l'intégration des contrôles, de l'audio et de la déco le temps de recevoir l'écran, les câbles USB/HDMI pour ce dernier, et le ventilo.

Edit 2: Bon bah c'est revenu dès que j'ai paramétré les contrôles sur le GPIO ; et j'ai trouvé le problème: le bouton on/off était AUSSI pris en compte comme le bouton hotkey P2 (alors que j'ai paramétré les commandes pour qu'il n'y ait qu'un seul joueur). J'ai viré le on/off, câblé le start P1 sur le démarreur, et vroom cette fois ça fonctionne.
#399559 par Arvester
11 Juil 2017, 16:33
Pour le moment il y a peu de choses à voir:

-j'ai pas encore d'écran donc l'image est sur la télé
-le son est trop faible donc j'attends de recevoir un ampli audio 5V
-les commandes du volant sont à perfectionner, j'ai bidouillé un truc mais je vais remplacer ça par des microswitches pour monnayeur de ce style.
-j'ai encore plusieurs boutons à câbler/créer (hotkey P1 et Y principalement)
-il faut câbler toute la déco, gyrophare et clignotants.

Bref, ça progresse doucement, je fais deux pas en avant et un pas en arrière. Juste un truc TROP bien: Virtua Racing fonctionne nickel (enfin, la version Deluxe sur 32X)
#399580 par Arvester
11 Juil 2017, 22:49
Cet aprem j'ai câblé la clé de contact sur Start et le reset kilométrique sur Hotkey. Et j'ai attaqué la déco:

Image
Les phares fonctionnent, mais les ampoules du gyrophare sont claquées toutes les deux. J'ai acheté des LED clignotantes en 5V, je les recevrai d'ici 2 ou 3 semaines...
#399615 par CaptainBigleux
12 Juil 2017, 13:24
t'es un grand malade, mais j'adore !
#399619 par anonyme26
12 Juil 2017, 15:01
je peux poster ta vidéo sur le twitter du forum ?

en tout cas j'ai hâte de voir le truc fini et comment tu vas personnaliser le tout :)
#399622 par shaokahn
12 Juil 2017, 15:21
Excellent. Par contre c'est moi ou la volant n'est pas droit quand tu vas tout droit... (légèrement incliné sur la droite).
#399623 par Arvester
12 Juil 2017, 15:23
Oui si tu veux Rezga. En effet le volant est décalé, le système que j'ai bricolé pour tester est temporaire, j'attends des microswitches pour monnayeurs pour modifier ça et rendre le système plus stable... en fait c'est presque injouable pour le moment :lol:
#399626 par Anonyme01
12 Juil 2017, 16:36
C'est magnifique :20-20:

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité